Customisation DB Extension

Discuss the phpBB forum software here as well as anything that pertains to it.

Moderator: phpBB Experts

Array
Dimetrodon
Not A Dinosaur!
Not A Dinosaur!
Posts: 197
Joined: Mon Sep 12, 2022 9:30 am
Verification: ✅ Elon Musk Style

Customisation DB Extension

Post by Dimetrodon »

I decided to take a look at the customization db extension that phpBB uses on their website.

I see we're off to a very good start already.
Composer wrote:Root composer.json requires php ^7.1.3 but your php version (8.1.6) does not satisfy that requirement.
That stopped being supported in 2019 and it was a prototype php version: https://prototype.php.net/versions/7.1.3/

Makes me wonder if that's what phpBB.com runs. Christ, that's an old php version.

Array
GanstaZ
Administrator
Administrator
Posts: 97
Joined: Sat Mar 11, 2023 8:50 am

Re: Customisation DB Extension

Post by GanstaZ »

Based on the info that i see.. it's for 3.3 branch & that branch has a set minimum version for php - 7.1.3.
I do not know what version they run at the moment, but i doubt it's +8.

Many of us have pointed out many issues to the team & that they should release master branch as whatever version they want/prefer..
But seems whatever we did/do can be compared to Don Quixote fight against windmills. In other words.. waste of time)

CDB is not as popular as it was anymore.. I think many of them know that glory time is over.. at least for current moment.
Trying to prove something that is not relevant + unnecessary notification notice/s that were caused by it.. are time wasting for everyone.

If they wont release 3.4 or whatever version it would be soon.. then we can consider it as the end.
I'm not looking at phpbb from the side/angle of regular/normal user/consumer.. but from the side of extension development & it seems as a project that is losing its hmm.. hard to even find perfect word for it.
Usus est magister optimus!
When answer lies in the question, question becomes redundant!

Array
Dimetrodon
Not A Dinosaur!
Not A Dinosaur!
Posts: 197
Joined: Mon Sep 12, 2022 9:30 am
Verification: ✅ Elon Musk Style

Re: Customisation DB Extension

Post by Dimetrodon »

I just found it funny, since 7.1.3 is not the minimum required version in this case, but is the required version. As in, you must have 7.1.3 or the extension is not going to work right. Unlike phpBB, which can work on newer php versions.

But yeah, I'm done. Sorry if you got notifications because of what I did.